Results 1 to 4 of 4

Thread: Disabling Frame Buffer in Ubuntu 10.04 Server

  1. #1
    Join Date
    Nov 2006
    Location
    UK
    Beans
    153
    Distro
    Ubuntu 10.04 Lucid Lynx

    Disabling Frame Buffer in Ubuntu 10.04 Server

    Hello,

    Does anyone know how to disable the frame buffer in Ubuntu 10.04 Server?

    It doesn't seem to take any notice if you use nofb or fb=false as a kernel argument and the terminal text scroll slowing down compiling a lot when running in a VirtualBox virtual machine.

    Many thanks,

    Graham

  2. #2
    Join Date
    May 2007
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Disabling Frame Buffer in Ubuntu 10.04 Server

    I was able to disable the framebuffer by adding a blacklist entry for my particular vga driver into /etc/modprobe.d/blacklist-framebuffer.conf.

    Added "blacklist vga16fb" (without the quotes) to the end of the list of other framebuffer drivers already there. Worked like a charm, got the nice, fast, classic console back.

    You can use dmesg to determine which driver, e.g. vga16fb, the framebuffer is loading. Should be towards the end of the output, right after a boot.

    To keep things extra clean, I un-commented GRUB_TERMINAL=console in /etc/default/grub to prevent GRUB from starting a framebuffer, but it's not really necessary.

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Beans
    153
    Distro
    Ubuntu 10.04 Lucid Lynx

    [Solved] Re: Disabling Frame Buffer in Ubuntu 10.04 Server

    Excellent, thank you very much! I might be able to compile PHP now in less than half an hour!

    Thanks,

    Graham

  4. #4
    Join Date
    Feb 2009
    Beans
    6

    Re: Disabling Frame Buffer in Ubuntu 10.04 Server

    A nicer solution (for me) to disable framebuffer was to use the nomodeset kernel boot option.

    Also, if you run your compiles in screen, then you need not watch all text to be drawn to the terminal. This is also useful if you use a slow ssh connection.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •